Splasm Software Discussions

a user community for the betterment of Splasmkind
It is currently Fri Dec 13, 2019 10:39 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Sat Jan 17, 2009 12:53 pm 
Offline

Joined: Sat Jan 17, 2009 12:37 pm
Posts: 3
Every time I launch iTunes (current version), it determines gapless playback information for all of my Audiobookbuilder - built audiobooks.

I've tried marking them gapless, letting it analyze them, but it still does it. I then unmark them as gapless, and restart, and it still does it.

I've tried removing them from the library and re-adding them, and it still does it.

What does ABB set that causes this to always occur? It happens on EVERY book that I've created with it.


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 25, 2009 12:24 am 
Offline

Joined: Tue Nov 04, 2008 5:03 pm
Posts: 3
I get the same thing. It also checks them every time i convert a file from one format to another. This is a major pain. Splasm please fix this issue.


Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 7:16 am 
Offline

Joined: Sun Jan 06, 2008 8:18 am
Posts: 24
Here, too. Extremely frustrating. I've noticed on some other forums that this appears to happen with tracks that are added (possibly ripped?) to iTunes from another program. I wonder if it would help to delete the track from iTunes then restore from the trash?

The more books I rip the ABB, the longer my gapless check takes. Arrgh!

- John

_________________
- John
New Mac user and avid audiobook "reader"
Mac Pro, 2.66 GH, 5 GB Ram, 1.5 TB storage


Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 11:09 am 
Offline
Administrator
Administrator
User avatar

Joined: Thu May 19, 2005 12:19 am
Posts: 532
Location: Prescott, WI, USA
We have not seen this behavior on any of our test machines. There may be an issue with how iTunes is storing gapless playback information on your machine. You could try unchecking the crossfade option in preferences to see if that stops the gapless checks (I believe iTunes uses that data to crossfade, whether that item is part of a gapless album or not), or you could try creating a new library by holding option when you start up iTunes to see if the same problem exists with a fresh library. You can always hold option in startup of iTunes to choose your old library again.

We do not include any gapless information or set audiobooks as a gapless track when they are transferred to iTunes.

_________________
Randy Knoble
Splasm Software
www.Splasm.com


Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 5:02 pm 
Offline

Joined: Sat Jan 17, 2009 12:37 pm
Posts: 3
Just an update for everyone - I worked with the devs, and did a number of tests, including new libraries, new files, etc. The only thing that seemed to work is a new user on the mac, but that could be coincidence, since not every file does it.

The only solution I found was to convert the files using the 'advanced menu'. I lose chapter marks (but it still remembers my position), and changes the files from .m4b to .m4a. That solved the issue, and for me, is a decent workaround.


Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 8:37 pm 
Offline

Joined: Sun Jan 06, 2008 8:18 am
Posts: 24
It only happens to me when I sync to iPod and only for books created with Audiobook builder. Here's another discussion happening at iLounge http://forums.ilounge.com/showthread.php?p=1320129#post1320129

_________________
- John
New Mac user and avid audiobook "reader"
Mac Pro, 2.66 GH, 5 GB Ram, 1.5 TB storage


Top
 Profile  
Reply with quote  
PostPosted: Fri Mar 06, 2009 8:10 am 
Offline
Administrator
Administrator
User avatar

Joined: Thu May 19, 2005 12:19 am
Posts: 532
Location: Prescott, WI, USA
Have you tried restoring your iPod to factory settings, and updating it to the latest software version? You may also want to try switching it from automatic sync to manual sync to see if it changes your situation.

_________________
Randy Knoble
Splasm Software
www.Splasm.com


Top
 Profile  
Reply with quote  
PostPosted: Fri Mar 06, 2009 9:57 am 
Offline

Joined: Sat Jan 17, 2009 12:37 pm
Posts: 3
It happens regardless of the state of the iPod - it's an interaction between the m4b files and iTunes.

is there an easy way to prevent ABB from automatically adding the books to iTunes? I'd like to try manually adding them and see if that's the issue.


Top
 Profile  
Reply with quote  
PostPosted: Fri Mar 06, 2009 9:35 pm 
Offline
Administrator
Administrator
User avatar

Joined: Thu May 19, 2005 12:19 am
Posts: 532
Location: Prescott, WI, USA
You can turn off adding the files to the iTunes in the Audiobook Builder preferences.

_________________
Randy Knoble
Splasm Software
www.Splasm.com


Top
 Profile  
Reply with quote  
PostPosted: Wed Oct 07, 2009 10:23 am 
Offline

Joined: Wed Oct 07, 2009 9:20 am
Posts: 5
Location: Hamburg, Germany
I had the same problem. On startup, iTunes (9.0.1) would repeatedly scan some (!) files created and imported with Audiobook Builder (1.1.2). On top of that, the meta data (Artist, Album, etc) of those files would not be editable in iTunes.

I tried fixing permissions in Finder and Terminal, to no avail.

I tried renaming the file endings from .m4b to .m4a in Finder. For one file that actually worked, and though I renamed it back to .m4b afterwards it could still be edited in iTunes. For most files this didn't work.

I finally got something to work that fixes the problem of files not being editable and files being scanned over and over again on iTunes start-up. It goes like this.

1) Locate the file created in Audiobook Builder either through "Show in Finder" in iTunes or directly from where it was saved.

2) Open the file in QuickTime Player (7.6.4).

3) Open menu "Window" -> "Show Movie Properties" (command-j) and edit the meta data fields you want to change.

4) Hit menu "File" -> "Save" (command-s) and enter a new file name. Don't mind the ending .mov for the file. The chapter markers, album cover, etc, are saved in the new file.

5) Quit QT.

6) Optionally rename the file ending back to .m4b.

7) Drag the new file into iTunes.

8) Enjoy!

I tested that the chapters are still intact when played in iTunes and on the iPhone. The meta data can now be edited in iTunes and the it won't be scanned again on start-up.

I hope this helps some of you!
- Manuel


Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 12, 2009 5:09 pm 
Offline
Administrator
Administrator
User avatar

Joined: Wed May 18, 2005 11:19 pm
Posts: 538
Location: Here and There
Can anyone with this issue select a track whose info can't be edited in iTunes, select Show in Finder from the File menu, select Get Info from the File menu and send us a screenshot of the Info window?

_________________
Keith Gugliotto
Primordial Sea Captain
Splasm Software
http://www.splasm.com

Follow us on Twitter!


Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 19, 2009 2:55 pm 
Offline
Administrator
Administrator
User avatar

Joined: Wed May 18, 2005 11:19 pm
Posts: 538
Location: Here and There
The other day I had a situation where I added some MP3's to an iTunes Library via AppleScript (3rd-party apps like Audiobook Builder will generally add tracks this way) and a handful of them ended up uneditable in iTunes. All tracks were unlocked and writable according to the Finder. Re-adding one of them by drag and drop resulted in an editable track. I didn't get a chance to test relaunching iTunes but restarting the Mac and then launching iTunes I found that all of the previously uneditable tracks were editable. I'll probably play with adding massive numbers of tracks via AppleScript this afternoon to see if I can catch the issue again.

_________________
Keith Gugliotto
Primordial Sea Captain
Splasm Software
http://www.splasm.com

Follow us on Twitter!


Top
 Profile  
Reply with quote  
PostPosted: Wed Feb 10, 2010 9:09 am 
Offline

Joined: Wed Oct 07, 2009 9:20 am
Posts: 5
Location: Hamburg, Germany
After browsing through several other forums about this weird behaviour in iTunes I found a solution to this problem for me that does not entail above mentioned method of reimporting or even re-encoding the files. It seems that the files can not be edited while iTunes performs a sound check on them. For large files this seem to take forever. iTunes might also have some other problems with handling a large number of files.

To solve this issue the option called Sound Check has to be switched-off for iTunes not to scan any files. The downside for some may be that if Sound Check is disabled iTunes will no longer automatically adjust the output level of any of your songs.

Disable Sound Check? Sounds simple enough, you say? Well, the tricky part is, that you have to find all the checkboxes in iTunes that offer this feature. Here are the ones I found (using iTunes 9.0.3 on a Mac):

  • in iTunes Preferences in the Playback tap, third checkbox from the top.
  • you have to disable Sound Check on all iPods/iPhones you have ever(!) synchronized with iTunes and re-synchronize them again afterwards. For example on the iPhone/iPod Touch go to Settings, scroll down to iPod, and switch-off the second switch from the top. Resynchronize.
  • select one of your playlists. It does not matter which one. If you do not have any, create one and add a song. Now right-click the playlist and select Burn Playlist to Disc or click the Burn Disc button in the bottom right corner that appears when you select the playlist. In the dialog box that opens now disable Sound Check. Click the Burn button and then cancel the operation by clicking the x in the iTunes display.

If you can find more locations that I have missed, please add to this threat.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group