Splasm Software Discussions

a user community for the betterment of Splasmkind
It is currently Sun Sep 15, 2019 5:10 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Fri Aug 30, 2019 2:54 pm 
Offline

Joined: Tue Aug 27, 2019 8:09 am
Posts: 1
Hi there!

I recently noticed a bug when the audiobook containers are written. No matter how you get audio data into ABB as soon as you write an audiobook (m4a or m4b, aac or aac-he) the book somehow is written as video container.

It plays fine in itunes and on iOS devices, but you can't use macOS' quicklook preview. I noticed the issue with the generated files when I tried to upload the files to the tonies.de cloud. They couldn't process the files.

As soon as you do the following with the files
Code:
ffmpeg -i generated.m4b -acodec copy -vcodec copy fixed.m4b

the files work just fine.

There must be an issue with container as the streams are fine (thus the copy option of ffmpeg works fine)

Rico

PS: I can't share sample files publicly (copyright!) but I'm fine with sending a sample file to the developers if needed :-)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group